FAQSearchLoginRegister
It is currently Mon Jan 22, 2018 9:29 pm

All times are UTC - 7 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
 Access Denied Errors 
Author Message

Joined: Sun Jul 05, 2009 8:38 pm
Posts: 46
Post Access Denied Errors
I have just upgraded our Control Center to 3.5. Upgrade succeeded and existing 3.1 agents connect OK and all details are visible.

Tried to upgrade an agent on NW 6.5 SP7 to 3.5 Upgraded OK but I cannot get the agent to connect to the Control Center. I get an access denied message.

Then installed on one of our new hosts (SLES 10 SP2, 64 bit, which is why we are upgrading) Installation went OK. Started Agent, completed details (Name and Rego code, etc) But I get an access denied message for this agent as well. The error message is shown below.

03-11-2011|15:31:15|[41802940]Register Agent RLAgent-ivclgw1 to Control Center.
03-11-2011|15:31:16|[41802940]Access to Control Center denied.
03-11-2011|15:31:16|[41802940]Could not register Agent RLAgent-ivclgw1. Access Denied.
03-11-2011|15:31:16|[41802940]CHECK REGISTRATION NAME AND CODE
03-11-2011|15:31:16|[41802940]IN THE AGENT .CONF FILE !
03-11-2011|15:31:16|[41001940]Agent Monitor Loop finished.

I have double checked and confirmed that all details in the rlagent.conf file are correct. There are no typos. The Control Center IP and port are correct. I have copied and pasted details from an exisiting, working agent so I am certain that all is OK. Something somewhere is mismatched, I guess, but I cannot see where.

Any help would be much appreciated.


Thu Mar 10, 2011 8:40 pm
Profile E-mail

Joined: Sun Jul 05, 2009 8:38 pm
Posts: 46
Post Re: Access Denied Errors
Further to the above I have also discovered that while the RLAgent on our Redline Control Center server is up an running and appears to be configured OK it is not connecting to the CC at all.

I see Host and Agent down alerts and the agent details in the Databse are still showing version 3.1. This would suggest that the agent has not been able to connect since the update was made.

I should also point out that all of our 3.1 agents are connecting properly; these have the same Control Center details entered in their conf files as the 3.5 agents which are not connecting properly.


Sun Mar 13, 2011 1:59 pm
Profile E-mail

Joined: Fri Jul 21, 2006 2:54 pm
Posts: 311
Post Re: Access Denied Errors
Hello,
There could be several reasons why it won't connect to the Control Center. For starters I would recommend getting your Redline agents on 3.5 if you can. It isn't necessary to have them on 3.5 but it is highly recommended to have everything on the same version if you can.

Usually the main reason why it doesn't connect to the Control Center is, as it states in the log file, that the registration name and code are not input into the rlagent.conf file correctly. Make sure that there are no spaces, and even typing it in by hand may help instead of copying. Verify the name and code in your Control Center.

Another reason why it can't connect is the agent name is already taken by something else within the system. Changing the name of the agent might help with this.

I would recommend contacting support on this issue and have them get remoted in and have a look to see what else could be the problem.

Thank you.


Thu Mar 17, 2011 5:57 pm
Profile

Joined: Sun Jul 05, 2009 8:38 pm
Posts: 46
Post Re: Access Denied Errors
We would love to get all our agents to 3.5. That is what we are trying to do now. The touble is that exisitng agents, including the agent on the Control Center server, when "upgraded" by following the instructions in the documentation can no longer communicate with the Control Center. We did not make any changes to the Registered Name and the Key in either the CC or the Agent conf files as part of the upgrade. Nothing has been changed in the config files at all.

I cannot go ahead and update the rest of the agents in that hope that they will continue to work.

I will raise a call with support and see if they can help at all.


Thu Mar 17, 2011 9:12 pm
Profile E-mail

Joined: Sun Jul 05, 2009 8:38 pm
Posts: 46
Post Re: Access Denied Errors
Support got on to this and remoted in to our system.

Turns out that the Registration Name cannot be more than 25 characters or so. Changing this at both the COntrol Center and in the agent conf files allowed the connection to establish OK.

All good now and I have got all our agents updated to latest level, now.


Wed Mar 30, 2011 3:40 pm
Profile E-mail

Joined: Fri Jul 21, 2006 2:54 pm
Posts: 311
Post Re: Access Denied Errors
Confirmed with development that the maximum amount of characters for the Registration Name and Code is 19 characters.


Tue Apr 12, 2011 11:57 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.